Back to overview
Degraded

Incident 572898122

Apr 22 at 11:47pm PDT
Affected services
Website - US_NC (EAST)
Izuro Cloud - US_NC (EAST)

Resolved
Apr 23 at 12:26pm PDT

Incident resolved, we're actively overseeing for any additional issues.

Created
Apr 22 at 11:47pm PDT

Our on-site engineers have been notified of e-mails failing to be sent. We are actively investigating the issue.

Impacted services: Login with Email, Login with SMS, SMS System, and Email System.